OSFP CISCO Command (Dokumentasi Irham)
# OSPF routing basic
- set ip interface
- R1(config-router)# router ospf 1
- R1(config-router)# network 192.168.0.0 0.0.0.255 area 0
- config di router ke 2
# OSPF Router-id (set manual)
- R1(config)# router ospf 1
- R1(config-router)# router-id 10.1.1.1
- R1# clear ip ospf clear | reload router
- Pemilihan router-id set manual, ip loopback terbesar atau ip int fisik terbesar
- Best practice set manual dan buat interface loopback
# OSPF authentikasi plain text
- R1(config)# int g0/0
- R1(config-if)# ip ospf authentication
- R1(config-if)# ip ospf authentication-key cisco-password
- config di router ke 2
# OSPF authentikasi MD5
- R1(config)# int g0/0
- R1(config-if)# ip ospf authentication message-digest
- R1(config-if)# ip ospf message-digest-key 1 md5 cisco-password
- config di router ke 2
# OSPF Passive interface
- R1(config)# router ospf 1
- R1(config-router)# passive-interface g0/3
# OSFP Ganti referensi bandwidth (cost = ref_bw/bw_interface)
- R1(config)# router ospf 1
- R1(config-router)# auto-cost reference-bandwidth 10000 (dalam Mb)
# OSPF Ubah interface bandwidth (utk mempengaruhi cost)
- R1(config)# int g0/0
- R1(config-if)# bandwidth 100000 (dalam Kb)
# OSPF Manipulasi cost (lebih simple)
- R1(config)# int g0/0
- R1(config-if)# ip ospf cost 20
# OSPF Load Balancing
- Load balancing terjadi saat cost menuju destination sama.
# OSPF Fail Over
- Fail over terjadi ketika link utama putus kemudian link backup up.
# OSPF Beda Jalur (Manipulasi cost, topologi seperti ring)
- R1(config)# int g0/0
- R1(config-if)# ip ospf cost 5
- R2(config)# int g0/1
- R2(config-if)# ip ospf cost 5
- R4(config)# int g0/1
- R4(config-if)# ip ospf cost 5
- R3(config)# int g0/0
- R3(config-if)# ip ospf cost 5
# OSPF menghindari beda jalur
- Samakan semua ospf cost di setiap interface dan router
# OSPF LSA dan LSDB
- LSA adalah informasi yg saling di pertukarkan oleh router
- LSA memiliki beberapa tipe yaitu dari LSA type 1 sampai LSA tpye 8
- LSA Type 1 (Router LSA)
=> Setiap router akan membuat router LSA
=> Membawa informasi tentang directly connected network
=> Hanya di flood di dalam area
=> show ip ospf database router (router-id)
- LSA Type 2 (Network LSA)
=> Dibuat oleh DR
=> Memuat informasi tentang router mana saja yang terhubung ke network
=> Hanya di flood di dalam area
=> show ip ospf database network (router-id)
- LSA Type 3 (Summary LSA)
=> Di buat oleh ABR
=> Membawa informasi tentang network dari area lain
=> LSA id nya adalah network dari area lain
=> show ip ospf database summary (router-id)
- LSA Type 4 (Summary ASBR LSA)
=> Dibuat oleh ABR
=> Menginformasikan tentang siapa ASBR di dalam jaringan OSPF
=> LSA type 4 tidak akan ada jika ABR dan ASBR berapa di area yg sama yaitu area 0, itu karena area 0 tidak ada melewati ABR
=> ABR adalah singkatan dari Area Border Router yang bertugas sebagai menghubungkan antar area
=> ASBR adalah singkatan dari Autonomous System Boundary Router yang bertugas sebagai menghubungkan jaringan ospf dengan jaringan luar, router yang melakukan redistribution.
=> show ip ospf database asbr-summary (router-id)
- LSA Type 5 (Autonomous System External LSA)
=> Dibuat oleh ASBR
=> Untuk membawa informasi tentang network jaringan luar (redistribute network)
=> show ip ospf database external (router-id)
- LSA Type 6 (Multicast OSPF LSA) Sangat jarang digunakan
- LSA Type 7 (Not-so-stubby area LSA) Sangat jarang digunakan
- LSA Type 8 (External attribute LSA for BGP) Sangat jarang digunakan
- LSDB adalah database hasil dari LSA
- Dalam satu area yg sama, router memiliki LSDB yg sama pula.
# OSPF Penentuan DR & BDR
- Router yang hidup duluan
- Priority tertinggi (default 1, bisa di set)
- Router-id tertinggi (IP add fisik tertinggi, ip loopback tertinggi atau di set)
# OSPF Point-to-Point (ganti network type, tidak perlu DR & BDR)
- R1(config-if)# ip ospf network point-to-point
- R2(config-if)# ip ospf network point-to-point
# OSPF Multi Area
- Untuk memudahkan manajemen
- Untuk membuat router bekerja/berfikir tidak terlalu keras yg dapat menyebabkan
router menjadi hang atau lambat menghitung best path/routing terbaik.
- Area 0 wajib ada
- Area 0 biasa juga disebut backbone area
- Setia area harus melewati area 0 untuk komunikasi dengan area lain
- Setiap area harus terhubung langsung dengan area 0
- ABR adalah Area border router, yaitu yg menghubungkan antar area
# OSPF Config ospf multi area
- buat satu video -> link
# OSPF Virtual Link
- Digunakan saat area lain tidak terhubung langsung dengan area backbone, yaitu area 0
- Untuk menghubungkan Virtual link di butuhkan transit area untuk menuju ke area 0
- Config virtual link di lakukan antara ABR ke ABR
- R2(config-router)# area 1 virtual-link (router-id dari router transit area)
- Lakukan juga di router lawan (config virtual link nya)
# OSPF Redistribution
- Digunakan untuk meng-advertise network dari routing protocol lain ke dalam ospf
- R1(config-router)# redistribute static subnets
- Untuk router tetangga yg bukan menggunakan protocol routing yg sama, misalnya
menggunakan routing static, router tersebut perlu membuat default router
- R20(config)# ip route 0.0.0.0 0.0.0.0 ip-gateway (network ospf ter-expose)
- Atau di R1 membuat nat utk ke network R20 (network OSFP tidak ter-expose)
# OSFP Stub Area
- stub area adalah area yg paling ujung
- Tidak menerima LSA type 4 & 5
- Dapat mengurangi beban/resource router
- Digantikan dengan default route
- Di config di semua router pada area tersebut (contoh area 1)
- R2(config-router)# area 1 stub
# OSPF Totally Stub Area
- Totally stub area adalah area yg paling ujung
- Tidak menerima LSA type 3, 4 & 5
- Dapat mengurangi beban/resource router
- Digantikan dengan default route
- Di config di router ABR
- R3(config-router)# area 1 stub no-summary
# OSPF TSHOOT
- Test Ping
- Cek Arp
- R1# debug ospf 1 adj
- R1# debug ospfv 1 packet
- R1# debug ip ospf hello
0 komentar:
Posting Komentar